Oxygen Sensor Testing

By Nils Powell
January 2001

O2 probes generate a voltage between OV and 1V depending on the O2 content of the exhaust gas surrounding the probe tip compared to the O2 content of the ambient air reaching the element via a vent in the sensor housing.

With a "good" sensor and motor, the voltage reading will swing rapidly between 0V and 1V as the electronics respond to inputs i.e. you will not have a steady reading. This combined with very low signal strength, means measurements can only realistically be made using a digital high impedance multimeter with a bar graph, or using specialised equipment.

Most sensors,including the ones we are talking about, have a Zirconia element that requires a tip temp of around 300C+ to produce a usable signal. This in turn means that probes without a built in heating element require an exhaust gas temp at the probe in excess of that produced at idle power, and to get a valid reading usually a minimum of 2500 RPM is required. - When a heater is built into the probe, which as far as I can tell is the case with all BMW bikes, there will be 4 wires connected to it as opposed to either 1 or 2. Measurements can then be made at lower engine speeds but they do need to be above idle to stabilise results - say 1500 RPM.

With a definite system fault (and a good O2 sensor) an engine running lean will cause the sensor to swing around a relatively low voltage (0.2V) and richness will cause the output voltage to swing high (0.8V) If no faults are present and everything is operating correctly the output will rapidly swing between 0V and 1V. Whilst the actual voltage measurement will fluctuate too rapidly to read consistently and is of no interest, the bar graph will rise and fall observably as will the mean of the swing. Once you have seen this effect on a good sensor it is easily recognised so if you are into this type of diagnostics, test your bike before a fault is suspected to get experience.

Testing - There is NO effective test available to the general workshop with the probe off the vehicle but the sensors are easy to test in situ.

First - The sensor is earthed and referenced to earth via its outer case the exhaust pipe, engine block and battery - this is true even of 2 and 4 wire systems. Check for voltage drops and make sure the probe is secure and the earths are good. Make sure visually that the venting orifice is clear and externally the sensor is clean.

Second - Get the motor up to temp, after a good highish RPM run, and establish a fast idle so that the exhaust gas stream (and heater if fitted) is hot enough to allow the sensor to operate (above say 1500 RPM). Probe the output (backprobing at the first plug up from the sensor is a good spot) and make sure the voltage is rapidly swinging as described.

To test further, create lean and rich conditions:

About the only common faults are bad earths, dirt on the sensor body, and age related failure when the output gets sluggish and slows or even stops - this usually takes about 70K miles or longer although failure will be almost immediate if leaded petrol or silicon based sealants have been used where they can reach the probe or combustion process. A sluggish sensor or one that fails to respond to rich and lean conditions instantly, has to be replaced, they are not repairable.

Now to the question of compatibility with aftermarket probes. Never having had to replace a BMW bike O2 sensor I can only describe how I would go about it!

Obviously there has to be a physical fit. Then there is the wiring configuration. Sensors come with 1, 2, 3, 4, and 5 wires. As far as I know all BMW bikes come with a four wire probe and this will not be specific to bikes. Two wires will be to the element heater. Two will be the O2 sensor circuit.

Incidentally the wires from the probe to the first connector will NOT reflect the proper harness colours. All colours are per the harness beyond the first connector which should only be a few inches up from the sensor. If the connector as well as the probe dimensions are compatible it should be safe to try, but easier still is to check the suppliers cross reference chart. It may not contain bike information but if the probe fits, the plug matches, and is usable on BMW cars or other Bosch supplied systems then it should be OK.

As far as I can tell all the bikes use the same sensor with 4 wires coloured as follows.

K1100
Gn/W & Br:     Heater
Br & Y:        Sensor (Y = signal)

K1200
Gn/W & Gn/Br:  Heater
Y & Bk:        Sensor (Y = signal)

Good luck!

 

All contents Copyright © 1995 - 2014 Internet BMW Riders & the original author(s)

K-Bike Tech Pages

Maintainer: Tom Coradeschi WWW - email
Last Update: 05 October 2007